GitHub Advisoryadvisory · Go

GHSA-gvh9-xgrq-r8hw Rancher's Steve API Component Improper authorization check allows privilege escalation

HIGH Published 2024-04-24 Modified 2024-07-08 Official page ↗
Aliases
CVE-2021-36776
Ecosystem
Go
Packages
github.com/rancher/rancher
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-284
Reviewed
2024-04-24

Affected packages

• Go github.com/rancher/rancher: >= 2.5.0, < 2.5.10 → fixed in 2.5.10

Description

Impact A flaw discovered in Rancher versions from 2.5.0 up to and including 2.5.9 allows an authenticated user to impersonate any user on a cluster through the Steve API proxy, without requiring knowledge of the impersonated user's credentials. This is due to the Steve API proxy not dropping the impersonation header before sending the request to the Kubernetes API. A malicious user with authenticated access to Rancher could use this to impersonate another user with administrator access in Rancher, receiving, then, administrator level access in the cluster. Patches Patched versions include releases 2.5.10, 2.6.0 and later versions. Workarounds Limit access in Rancher to trusted users. There is not a direct mitigation besides upgrading to the patched Rancher versions. For more information If you have any questions or comments about this advisory: • Reach out to SUSE Rancher Security team for security related inquiries. • Open an issue in Rancher repository. • Verify our support matrix and product support lifecycle.

Related

Alias · CVE (1)

  • CVE-2021-36776 A Improper Access Control vulnerability in SUSE Rancher allows remote attackers impersonate arbitrary users. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References