GitHub Advisoryadvisory · Go

GHSA-gw5h-h6hj-f56g Gogs vulnerable to improper PAM authorization handling

HIGH Published 2022-03-14 Modified 2023-06-30 Official page ↗
Aliases
CVE-2022-0871
Ecosystem
Go
Packages
gogs.io/gogs
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-862
Reviewed
2022-03-14

Affected packages

• Go gogs.io/gogs: < 0.12.5 → fixed in 0.12.5

Description

Impact Expired PAM accounts and accounts with expired passwords are continued to be seen as valid. Installations use PAM as authentication sources are affected. Patches Expired PAM accounts and accounts with expired passwords are no longer being seen as valid. Users should upgrade to 0.12.5 or the latest 0.13.0+dev. Workarounds In addition to marking PAM accounts as expired, also disable/lock them. Running `usermod -L ` will add an exclamation mark to the password hash and would result in wrong passwords responses when trying to login. References https://huntr.dev/bounties/ea82cfc9-b55c-41fe-ae58-0d0e0bd7ab62/ For more information If you have any questions or comments about this advisory, please post on https://github.com/gogs/gogs/issues/6810.

Related

Alias · CVE (1)

  • CVE-2022-0871 Missing Authorization in GitHub repository gogs/gogs prior to 0.12.5. vulnerability

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References