GitHub Advisoryadvisory · PyPI
GHSA-gw84-84pc-xp82 Cross-site Scripting in djangorestframework
LOW
Official page ↗
- Aliases
- CVE-2024-21520
- Ecosystem
- PyPI
- Packages
- djangorestframework
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-06-26
Affected packages
• PyPI djangorestframework: < 3.15.2 → fixed in 3.15.2
Description
Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with tags.
Related
Alias · CVE (1)
- CVE-2024-21520 Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-21520 advisory
- https://github.com/encode/django-rest-framework/pull/9435 web
- https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642 web
- https://github.com/encode/django-rest-framework package
- https://github.com/encode/django-rest-framework/compare/3.15.1...3.15.2 web
- https://security.snyk.io/vuln/SNYK-PYTHON-DJANGORESTFRAMEWORK-7252137 web