GitHub Advisoryadvisory · PyPI

GHSA-gwqq-6vq7-5j86 langchain Code Injection vulnerability

CRITICAL Published 2023-08-05 Modified 2024-09-27 Official page ↗
Aliases
CVE-2023-36095
Ecosystem
PyPI
Packages
langchain
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-08-09

Affected packages

• PyPI langchain: < 0.0.236 → fixed in 0.0.236

Description

An issue in Harrison Chase langchain allows an attacker to execute arbitrary code via the PALChain,from_math_prompt(llm).run in the python exec method.

Related

Alias · CVE (1)

  • CVE-2023-36095 An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain,… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References