GitHub Advisoryadvisory · PyPI

GHSA-gwr8-5j83-483c OS Command Injection and Improper Input Validation in ansible

HIGH Published 2021-04-20 Modified 2024-09-06 Official page ↗
Aliases
CVE-2019-14904
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L
Weaknesses
CWE-20, CWE-78
Reviewed
2021-04-05

Affected packages

• PyPI ansible: < 2.7.16 → fixed in 2.7.16 • PyPI ansible: >= 2.8.0a1, < 2.8.8 → fixed in 2.8.8 • PyPI ansible: >= 2.9.0a1, < 2.9.3 → fixed in 2.9.3

Description

A flaw was found in the solaris_zone module from the Ansible Community modules. When setting the name for the zone on the Solaris host, the zone name is checked by listing the process with the 'ps' bare command on the remote machine. An attacker could take advantage of this flaw by crafting the name of the zone and executing arbitrary commands in the remote host. Ansible Engine 2.7.15, 2.8.7, and 2.9.2 as well as previous versions are affected.

Related

Alias · CVE (1)

  • CVE-2019-14904 A flaw was found in the solaris_zone module from the Ansible Community modules. vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References