GitHub Advisoryadvisory · npm
GHSA-gx6r-qc2v-3p3v systeminformation SSID Command Injection Vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2023-42810
- Ecosystem
- npm
- Packages
- systeminformation
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2023-09-21
Affected packages
• npm systeminformation: >= 5.0.0, < 5.21.7 → fixed in 5.21.7
Description
Impact
SSID Command Injection Vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.21.7, Version 4 was not affected
Workarounds
If you cannot upgrade, be sure to check or sanitize parameter strings that are passed to wifiConnections(), wifiNetworks() (string only)
References
See also https://systeminformation.io/security.html
Related
Alias · CVE (1)
- CVE-2023-42810 systeminformation is a System Information Library for Node.JS. vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v web
- https://nvd.nist.gov/vuln/detail/CVE-2023-42810 advisory
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392 web
- https://github.com/sebhildebrandt/systeminformation package
- https://systeminformation.io/security.html web