GitHub Advisoryadvisory · RubyGems

GHSA-gx8x-g87m-h5q6 Denial of Service (DoS) in Nokogiri on JRuby

HIGH Published 2022-04-11 Modified 2022-04-11 Official page ↗
Ecosystem
RubyGems
Packages
nokogiri
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2022-04-11

Affected packages

• RubyGems nokogiri: < 1.13.4 → fixed in 1.13.4

Description

Summary Nokogiri `v1.13.4` updates the vendored `org.cyberneko.html` library to `1.9.22.noko2` which addresses CVE-2022-24839. That CVE is rated 7.5 (High Severity). See GHSA-9849-p7jc-9rmv for more information. Please note that this advisory only applies to the JRuby implementation of Nokogiri `= 1.13.4`. Impact CVE-2022-24839 in nekohtml • Severity: High 7.5 • Type: CWE-400 Uncontrolled Resource Consumption • Description: The fork of `org.cyberneko.html` used by Nokogiri (Rubygem) raises a `java.lang.OutOfMemoryError` exception when parsing ill-formed HTML markup. • See also: GHSA-9849-p7jc-9rmv

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References