GitHub Advisoryadvisory · npm, NuGet, RubyGems, Maven, Packagist

GHSA-gxr4-xjj5-5px2 Potential XSS vulnerability in jQuery

MEDIUM Published 2020-04-29 Modified 2026-07-09 Official page ↗
Aliases
CVE-2020-11022
Ecosystem
npm, NuGet, RubyGems, Maven, Packagist
Packages
jquery, jquery-rails, org.webjars.npm:jquery, maximebf/debugbar, athlon1600/youtube-downloader, components/jquery
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-04-29

Affected packages

• npm jquery: >= 1.12.0, < 3.5.0 → fixed in 3.5.0 • NuGet jquery: >= 1.12.0, < 3.5.0 → fixed in 3.5.0 • RubyGems jquery-rails: < 4.4.0 → fixed in 4.4.0 • Maven org.webjars.npm:jquery: >= 1.12.0, < 3.5.0 → fixed in 3.5.0 • Packagist maximebf/debugbar: < 1.19.0 → fixed in 1.19.0 • Packagist athlon1600/youtube-downloader: < 4.0.1 → fixed in 4.0.1 • Packagist components/jquery: >= 1.12.0, < 3.5.0 → fixed in 3.5.0

Description

Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. `.html()`, `.append()`, and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround the issue without upgrading, adding the following to your code: ```js jQuery.htmlPrefilter = function( html ) { return html; }; ``` You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.

Related

Alias · CVE (1)

  • CVE-2020-11022 In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References