GitHub Advisoryadvisory · Packagist
GHSA-gxxj-g9v8-w28p Drupal core Arbitrary PHP code execution
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-05-15
Affected packages
• Packagist drupal/core: >= 7.0.0, < 7.75 → fixed in 7.75
• Packagist drupal/core: >= 8.0.0, < 8.8.12 → fixed in 8.8.12
• Packagist drupal/core: >= 8.9.0, < 8.9.10 → fixed in 8.9.10
• Packagist drupal/core: >= 9.0.0, < 9.0.9 → fixed in 9.0.9
Description
The Drupal project uses the PEAR Archive_Tar library. The PEAR Archive_Tar library has released a security update that impacts Drupal. For more information please see:
CVE-2020-28948
CVE-2020-28949
Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2, or .tlz file uploads and processes them.
To mitigate this issue, prevent untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files.
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness