GitHub Advisoryadvisory · Maven

GHSA-h259-74h5-4rh9 XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API

HIGH Published 2026-04-08 Modified 2026-04-08 Official page ↗
Aliases
CVE-2026-33229
Ecosystem
Maven
Packages
org.xwiki.platform:xwiki-platform-oldcore, org.xwiki.platform:xwiki-platform-legacy-oldcore
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-862
Reviewed
2026-04-08

Affected packages

• Maven org.xwiki.platform:xwiki-platform-oldcore: >= 17.0.0-rc-1, < 17.4.8 → fixed in 17.4.8 • Maven org.xwiki.platform:xwiki-platform-oldcore: >= 17.5.0-rc-1, < 17.10.1 → fixed in 17.10.1 • Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: >= 17.0.0-rc-1, < 17.4.8 → fixed in 17.4.8 • Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: >= 17.5.0-rc-1, < 17.10.1 → fixed in 17.10.1

Description

Impact An improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. Patches The vulnerability has been patched in XWiki 17.4.8 and 17.10.1 by requiring programming right to access the affected scripting API. Workarounds We're not aware of any workarounds except for being careful whom you grant script right. Attribution We thank Youssef Azefzaf for discovering and reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-33229 XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. vulnerability

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References