GitHub Advisoryadvisory · npm
GHSA-h25m-26qc-wcjf Next.js HTTP request deserialization can lead to DoS when using insecure React Server Components
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-502
- Reviewed
- 2026-01-28
Affected packages
• npm next: >= 13.0.0, < 15.0.8 → fixed in 15.0.8
• npm next: >= 15.1.1-canary.0, < 15.1.12 → fixed in 15.1.12
• npm next: >= 15.2.0-canary.0, < 15.2.9 → fixed in 15.2.9
• npm next: >= 15.3.0-canary.0, < 15.3.9 → fixed in 15.3.9
• npm next: >= 15.4.0-canary.0, < 15.4.11 → fixed in 15.4.11
• npm next: >= 15.5.1-canary.0, < 15.5.10 → fixed in 15.5.10
• npm next: >= 15.6.0-canary.0, < 15.6.0-canary.61 → fixed in 15.6.0-canary.61
• npm next: >= 16.0.0-beta.0, < 16.0.11 → fixed in 16.0.11
• npm next: >= 16.1.0-canary.0, < 16.1.5 → fixed in 16.1.5
Description
A vulnerability affects certain React Server Components packages for versions 19.0.x, 19.1.x, and 19.2.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as CVE-2026-23864.
A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage, out-of-memory exceptions, or server crashes. This can result in denial of service in unpatched environments.
Related
References
- https://github.com/facebook/react/security/advisories/GHSA-83fc-fqcc-2hmg web
- https://github.com/vercel/next.js/security/advisories/GHSA-h25m-26qc-wcjf web
- https://nvd.nist.gov/vuln/detail/CVE-2026-23864 advisory
- https://github.com/vercel/next.js package
- https://vercel.com/changelog/summary-of-cve-2026-23864 web