GitHub Advisoryadvisory · npm

GHSA-h2pm-378c-pcxx Path traversal vulnerability in gatsby-plugin-sharp

MEDIUM Published 2023-04-20 Modified 2023-04-20 Official page ↗
Aliases
CVE-2023-30548
Ecosystem
npm
Packages
gatsby-plugin-sharp
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-22
Reviewed
2023-04-20

Affected packages

• npm gatsby-plugin-sharp: >= 5.0.0, < 5.8.1 → fixed in 5.8.1 • npm gatsby-plugin-sharp: < 4.25.1 → fixed in 4.25.1

Description

Impact The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server (`gatsby develop`). The following steps can be used to reproduce the vulnerability: ``` Create a new Gatsby project, and install gatsby-plugin-sharp $ npm init gatsby $ cd my-gatsby-site $ npm install gatsby-plugin-sharp Add the plugin to gatsby-config.js module.exports = { plugins: [ { resolve: `gatsby-plugin-sharp`, }, ] } Start the Gatsby develop server $ gatsby develop Execute the path traversal vulnerability $ curl "http://127.0.0.1:8000/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/etc/passwd" ``` It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. Patches A patch has been introduced in `[email protected]` and `[email protected]` which mitigates the issue by ensuring that included paths remain within the project directory. Workarounds As stated above, by default `gatsby develop` is only exposed to the localhost `127.0.0.1`. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability. We encourage projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner. Credits We would like to thank Patrick Rombouts and Bart Veneman [drukwerkdeal.nl] for bringing the issue to our attention. For more information Email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2023-30548 gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References