GitHub Advisoryadvisory · Packagist

GHSA-h34c-px28-rjgw Moodle mishandles group-based authorization checks

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5268
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.10 → fixed in 2.7.10 • Packagist moodle/moodle: >= 2.8.0, < 2.8.8 → fixed in 2.8.8 • Packagist moodle/moodle: >= 2.9.0, < 2.9.2 → fixed in 2.9.2

Description

The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based authorization checks, which allows remote authenticated users to obtain sensitive information by reading a rating value.

Related

Alias · CVE (1)

  • CVE-2015-5268 The rating component in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 mishandles group-based… vulnerability

References