GitHub Advisoryadvisory · Go
GHSA-h356-3mfw-x368 Mattermost Fails to Verify User's Permissions When Accessing Groups
MEDIUM
Official page ↗
- Aliases
- CVE-2025-2527
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-05-17
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.3 → fixed in 10.5.3
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.12 → fixed in 9.11.12
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250411064244-844447fbd57c → fixed in 8.0.0-20250411064244-844447fbd57c
Description
Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 failed to properly verify a user's permissions when accessing groups, which allows an attacker to view group information via an API request.
Related
Alias · CVE (1)
- CVE-2025-2527 Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 failed to properly verify a user's permissions when accessing groups, which allows… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness