GitHub Advisoryadvisory · RubyGems
GHSA-h3r8-h5qw-4r35 sidekiq vulnerable to cross-site scripting
HIGH
Official page ↗
- Aliases
- CVE-2023-1892
- Ecosystem
- RubyGems
- Packages
- sidekiq
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2023-04-24
Affected packages
• RubyGems sidekiq: >= 7.0.4, < 7.0.8 → fixed in 7.0.8
Description
sidekiq from 7.0.4 to 7.0.7 is vulnerable to reflected cross-site scripting. A fix was released in version 7.0.8.
Related
Alias · CVE (1)
- CVE-2023-1892 Cross-site Scripting (XSS) - Reflected in GitHub repository sidekiq/sidekiq prior to 7.0.8. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-1892 advisory
- https://github.com/sidekiq/sidekiq/commit/458fdf74176a9881478c48dc5cf0269107b22214 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sidekiq/CVE-2023-1892.yml web
- https://github.com/sidekiq/sidekiq package
- https://github.com/sidekiq/sidekiq/blob/main/Changes.md#708 web
- https://huntr.dev/bounties/e35e5653-c429-4fb8-94a3-cbc123ae4777 web