GitHub Advisoryadvisory · Packagist

GHSA-h3r9-pjmr-f938 Drupal Brute force amplification attacks via XML-RPC

HIGH Published 2022-05-17 Modified 2024-04-23 Official page ↗
Aliases
CVE-2016-3163
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 7.0, < 7.43 → fixed in 7.43 • Packagist drupal/core: >= 6.0, < 6.38 → fixed in 6.38 • Packagist drupal/drupal: >= 7.0, < 7.43 → fixed in 7.43 • Packagist drupal/drupal: >= 6.0, < 6.38 → fixed in 6.38

Description

The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks via a large number of calls made at once to the same method.

Related

Alias · CVE (1)

  • CVE-2016-3163 The XML-RPC system in Drupal 6.x before 6.38 and 7.x before 7.43 might make it easier for remote attackers to conduct brute-force attacks… vulnerability

References