GitHub Advisoryadvisory · Maven

GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability

CRITICAL Published 2026-08-26 Modified 2026-09-02 Official page ↗
Aliases
CVE-2026-68525
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-863
Reviewed
2026-09-02

Affected packages

• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat:tomcat: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat:tomcat: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat: >= 7.0.0, <= 7.0.109 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 7.0.0, <= 7.0.109 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.25 → fixed in 11.0.25 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.58 → fixed in 10.1.58 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0-M1, < 9.0.121 → fixed in 9.0.121 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 7.0.0, <= 7.0.109 (no fix yet)

Description

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-68525 Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References