GitHub Advisoryadvisory · Go
GHSA-h469-4fcf-p23h Mattermost has Potential Server Crash due to Unvalidated Import Data
MEDIUM
Official page ↗
- Aliases
- CVE-2025-8402
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v5, github.com/mattermost/mattermost-server/v6
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-476
- Reviewed
- 2025-08-22
Affected packages
• Go github.com/mattermost/mattermost-server: >= 10.8.0, < 10.8.4 → fixed in 10.8.4
• Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.9 → fixed in 10.5.9
• Go github.com/mattermost/mattermost-server: >= 10.9.0, < 10.9.4 → fixed in 10.9.4
• Go github.com/mattermost/mattermost-server: >= 10.10.0, < 10.10.1 → fixed in 10.10.1
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250708173752-d6b35c41f0ae5 → fixed in 8.0.0-20250708173752-d6b35c41f0ae5
• Go github.com/mattermost/mattermost-server: >= 9.11.0, < 9.11.18 → fixed in 9.11.18
• Go github.com/mattermost/mattermost-server/v5: <= 5.39.3 (no fix yet)
• Go github.com/mattermost/mattermost-server/v6: <= 6.7.2 (no fix yet)
Description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to validate import data which allows a system admin to crash the server via the bulk import feature.
Related
Alias · CVE (1)
- CVE-2025-8402 Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to validate import… vulnerability
Weakness · CWE (1)
- CWE-476 NULL Pointer Dereference weakness