GitHub Advisoryadvisory · PyPI
GHSA-h4gh-qq45-vh27 pyca/cryptography has a vulnerable OpenSSL included in cryptography wheels
MEDIUM
Official page ↗
- Ecosystem
- PyPI
- Packages
- cryptography
- Severity
- Moderate
- Weaknesses
- CWE-1395
- Reviewed
- 2024-09-03
Affected packages
• PyPI cryptography: >= 37.0.0, < 43.0.1 → fixed in 43.0.1
Description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-43.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20240903.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Related
Weakness · CWE (1)
- CWE-1395 Dependency on Vulnerable Third-Party Component weakness