GitHub Advisoryadvisory · npm

GHSA-h4j5-c7cj-74xg xmlhttprequest and xmlhttprequest-ssl vulnerable to Arbitrary Code Injection

CRITICAL Published 2021-05-04 Modified 2023-09-08 Official page ↗
Aliases
CVE-2020-28502
Ecosystem
npm
Packages
xmlhttprequest, xmlhttprequest-ssl
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2021-03-18

Affected packages

• npm xmlhttprequest: < 1.7.0 → fixed in 1.7.0 • npm xmlhttprequest-ssl: < 1.6.2 → fixed in 1.6.2

Description

This affects the package xmlhttprequest before 1.7.0; all versions of package xmlhttprequest-ssl. Provided requests are sent synchronously (`async=False` on `xhr.open`), malicious user input flowing into `xhr.send` could result in arbitrary code being injected and run.

Related

Alias · CVE (1)

  • CVE-2020-28502 This affects the package xmlhttprequest before 1.7.0; all versions of package xmlhttprequest-ssl. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References