GitHub Advisoryadvisory · npm

GHSA-h4jx-hjr3-fhgc OpenClaw: Gateway Plugin Subagent Fallback `deleteSession` Uses Synthetic `operator.admin`

MEDIUM Published 2026-03-29 Modified 2026-04-18 Official page ↗
Aliases
CVE-2026-35645
Ecosystem
npm
Packages
openclaw
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-266, CWE-648, CWE-863
Reviewed
2026-03-29

Affected packages

• npm openclaw: < 2026.3.28 → fixed in 2026.3.28

Description

Summary Gateway Plugin Subagent Fallback `deleteSession` Uses Synthetic `operator.admin` Affected Packages / Versions • Package: `openclaw` • Affected versions: `<= 2026.3.24` • First patched version: `2026.3.25` • Latest published npm version at verification time: `2026.3.24` Details Gateway plugin subagent fallback `deleteSession` previously dispatched `sessions.delete` with a synthetic `operator.admin` runtime scope when no request-scoped client existed. Commit `b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7` binds deletion to the caller scope instead of minting admin scope. Verified vulnerable on tag `v2026.3.24` and fixed on `main` by commit `b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7`. Fix Commit(s) • `b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7`

Related

Alias · CVE (1)

  • CVE-2026-35645 OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that… vulnerability

Weakness · CWE (3)

  • CWE-266 Incorrect Privilege Assignment weakness
  • CWE-648 Incorrect Use of Privileged APIs weakness
  • CWE-863 Incorrect Authorization weakness

References