GitHub Advisoryadvisory · Maven
GHSA-h533-q6jc-qx28 Cloud Foundry Runtime Insufficient Session Expiration vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2015-5171
- Ecosystem
- Maven
- Packages
- org.cloudfoundry.identity:cloudfoundry-identity-server
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-613
- Reviewed
- 2024-02-28
Affected packages
• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: < 2.5.2 → fixed in 2.5.2
Description
The password change functionality in Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow attackers to have unspecified impact by leveraging failure to expire existing sessions.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2015-5171 The password change functionality in Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5171 advisory
- https://github.com/cloudfoundry/uaa/commit/7c70a85f4c7b5a9b1603bc57cab14a7ffef2168b web
- https://github.com/cloudfoundry/uaa/commit/9730cd6a3bbb481ee4e400b51952b537589c469d web
- https://github.com/cloudfoundry/uaa package
- https://pivotal.io/security/cve-2015-5170-5173 web