GitHub Advisoryadvisory · PyPI

GHSA-h582-2pch-3xv3 Django Denial-of-service by filling session store

HIGH Published 2019-07-05 Modified 2024-09-18 Official page ↗
Aliases
CVE-2015-5143
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-770
Reviewed
2020-06-16

Affected packages

• PyPI Django: < 1.4.21 → fixed in 1.4.21 • PyPI Django: >= 1.5, < 1.7.9 → fixed in 1.7.9 • PyPI Django: >= 1.8, < 1.8.3 → fixed in 1.8.3

Description

The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.

Related

Alias · CVE (1)

  • CVE-2015-5143 The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References