GitHub Advisoryadvisory · NuGet
GHSA-h595-8pw6-5q6v Inadequate Encryption Strength in DotNetNuke
HIGH
Official page ↗
- Aliases
- CVE-2018-15811
- Ecosystem
- NuGet
- Packages
- DotNetNuke.Core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
- Weaknesses
- CWE-326
- Reviewed
- 2019-07-05
Affected packages
• NuGet DotNetNuke.Core: >= 9.2.0, < 9.2.2 → fixed in 9.2.2
Description
DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters.
Related
Alias · CVE (1)
- CVE-2018-15811 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. vulnerability
Weakness · CWE (1)
- CWE-326 Inadequate Encryption Strength weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-15811 advisory
- https://github.com/dnnsoftware/Dnn.Platform/releases web
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-15811 web
- https://www.dnnsoftware.com/community/security/security-center web
- http://packetstormsecurity.com/files/157080/DotNetNuke-Cookie-Deserialization-Remote-Code-Execution.html web