GitHub Advisoryadvisory · PyPI

GHSA-h5cg-53g7-gqjw RPyC's missing security check results in code execution when using numpy.array on the server-side.

HIGH Published 2024-03-06 Modified 2024-08-02 Official page ↗
Aliases
CVE-2024-27758
Ecosystem
PyPI
Packages
rpyc
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weaknesses
CWE-306, CWE-358, CWE-913
Reviewed
2024-03-06

Affected packages

• PyPI rpyc: >= 4.0.0, < 6.0.0 → fixed in 6.0.0

Description

An issue in Open Source: RPyC v.4.00 thru v.5.3.1 allows a remote attacker to execute arbitrary code via a crafted script to the `__array__` attribute component. This vulnerability was introduced in 9f45f826. Attack Vector RPyC services that rely on the `__array__` attribute used by numpy are impacted. When the server-side exposes a method that calls the attribute named `__array__` for a a client provided netref (e.g., `np.array(client_netref)`), a remote attacker can craft a class which results in remote code execution Impact Assuming the system exposes a method that calls the attribute `__array__`, an attacker can execute code using the vulnerable component. Patches The fix is available in RPyC 6.0.0. The major version change is because some users may need to set `allow_pickle` to `True` when migrating to RPyC 6. Workarounds While the recommend fix is to upgrade to RPyC 6.0.0, the workaround is to apply bba1d356 as patch. Affected Component The affected component is the `__array__` method constructed for `NetrefClass`. References • Original disclosure by renbou (Artem Mikheev) • CVE-2024-27758

Related

Alias · CVE (1)

  • CVE-2024-27758 In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g.,… vulnerability

Weakness · CWE (3)

  • CWE-306 Missing Authentication for Critical Functionality weakness
  • CWE-358 Improperly Implemented Security Check for Standard weakness
  • CWE-913 Improper Control of Dynamically-Managed Code Resources weakness

References