GitHub Advisoryadvisory · PyPI
GHSA-h5g4-ppwx-48q2 Missing validation causes denial of service via `DeleteSessionTensor`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29194
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-05-24
Affected packages
• PyPI tensorflow: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow-cpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-gpu: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow-gpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
Description
Impact
The implementation of `tf.raw_ops.DeleteSessionTensor` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack:
```python
import tensorflow as tf
handle = tf.constant("[]", shape=[0], dtype=tf.string)
tf.raw_ops.DeleteSessionTensor(handle=handle)
```
The code assumes `handle` is a scalar but there is no validation for this:
```cc
const Tensor& handle = ctx->input(0);
const string& name = handle.scalar()();
```
Patches
We have patched the issue in GitHub commit cff267650c6a1b266e4b4500f69fbc49cdd773c5.
The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou from Secure Systems Lab at Brown University.
Related
Alias · CVE (1)
- CVE-2022-29194 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h5g4-ppwx-48q2 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-29194 advisory
- https://github.com/tensorflow/tensorflow/commit/cff267650c6a1b266e4b4500f69fbc49cdd773c5 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/kernels/session_ops.cc#L128-L144 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0 web