GitHub Advisoryadvisory · PyPI

GHSA-h5gc-rm8j-5gpr LangChain Community SSRF vulnerability exists in RequestsToolkit component

HIGH Published 2025-06-23 Modified 2025-07-17 Official page ↗
Aliases
CVE-2025-2828
Ecosystem
PyPI
Packages
langchain-community
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-918
Reviewed
2025-06-25

Affected packages

• PyPI langchain-community: < 0.0.28 → fixed in 0.0.28

Description

A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.

Related

Alias · CVE (1)

  • CVE-2025-2828 A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package… vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References