GitHub Advisoryadvisory · Packagist

GHSA-h5h8-pc6h-jvvx Composer's missing argument delimiter can lead to code execution via VCS repository URLs or source download URLs on systems with Mercurial

HIGH Published 2021-04-29 Modified 2022-08-11 Official page ↗
Aliases
CVE-2021-29472
Ecosystem
Packagist
Packages
composer/composer
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-88, CWE-94
Reviewed
2021-04-27

Affected packages

• Packagist composer/composer: < 1.10.22 → fixed in 1.10.22 • Packagist composer/composer: >= 2.0.0-alpha1, < 2.0.13 → fixed in 2.0.13

Description

URLs for Mercurial repositories in the root composer.json and package source download URLs are not sanitized correctly. Specifically crafted URL values allow commands to be executed in the HgDriver if hg/Mercurial is installed on the system. Impact • The impact to Composer users directly is limited as the composer.json file is typically under their own control and source download URLs can only be supplied by third party Composer repositories they explicitly trust to download and execute source code from, e.g. Composer plugins. • The main impact is to services passing user input to Composer, including Packagist.org and Private Packagist. This allowed users to trigger remote command injection. The vulnerability has been patched on Packagist.org and Private Packagist within 12h of receiving the initial vulnerability report and based on a review of logs, to the best of our knowledge, was not abused by anyone. • Other services/tools using VcsRepository/VcsDriver or derivatives may also be vulnerable and should upgrade their composer/composer dependency immediately Patches 1.10.22 and 2.0.13 include patches for this issue.

Related

Alias · CVE (1)

  • CVE-2021-29472 Composer is a dependency manager for PHP. vulnerability

Weakness · CWE (2)

  • CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References