GitHub Advisoryadvisory · Packagist
GHSA-h632-p764-pjqm DataFlow upload remote code execution vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2021-41231
- Ecosystem
- Packagist
- Packages
- openmage/magento-lts
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-434, CWE-77
- Reviewed
- 2023-01-27
Affected packages
• Packagist openmage/magento-lts: < 19.4.22 → fixed in 19.4.22
• Packagist openmage/magento-lts: >= 20.0.0, < 20.0.19 → fixed in 20.0.19
Description
Impact
An administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile.
Related
Alias · CVE (1)
- CVE-2021-41231 OpenMage LTS is an e-commerce platform. vulnerability
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-h632-p764-pjqm web
- https://nvd.nist.gov/vuln/detail/CVE-2021-41231 advisory
- https://github.com/OpenMage/magento-lts/commit/d16fc6c5a1e66c6f0d9f82020f11702a7ddd78e4 web
- https://github.com/OpenMage/magento-lts package
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22 web
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19 web