GitHub Advisoryadvisory · Maven
GHSA-h642-5h74-3x9c Reflected Cross-site Scripting in Jenkins Nested View Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-34182
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:nested-view
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-07-05
Affected packages
• Maven org.jenkins-ci.plugins:nested-view: >= 1.20, < 1.26 → fixed in 1.26
Description
Jenkins Nested View Plugin 1.20 through 1.25 (both inclusive) does not escape search parameters, resulting in a reflected cross-site scripting (XSS) vulnerability.
Nested View Plugin 1.26 escapes search parameters
Related
Alias · CVE (1)
- CVE-2022-34182 Jenkins Nested View Plugin 1.20 through 1.25 (both inclusive) does not escape search parameters, resulting in a reflected cross-site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness