GitHub Advisoryadvisory · Maven

GHSA-h658-qqv9-qwv8 Apache NiFi vulnerable to Cross-site Scripting

MEDIUM Published 2024-07-08 Modified 2024-07-11 Official page ↗
Aliases
CVE-2024-37389
Ecosystem
Maven
Packages
org.apache.nifi:nifi-web-ui
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-07-08

Affected packages

• Maven org.apache.nifi:nifi-web-ui: >= 1.10.0, < 1.27.0 → fixed in 1.27.0 • Maven org.apache.nifi:nifi-web-ui: >= 2.0.0-M1, < 2.0.0-M4 → fixed in 2.0.0-M4

Description

Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.

Related

Alias · CVE (1)

  • CVE-2024-37389 Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References