GitHub Advisoryadvisory · Packagist

GHSA-h65r-8fp8-w7cx phpMyAdmin SQL Injection

HIGH Published 2022-05-24 Modified 2024-04-24 Official page ↗
Aliases
CVE-2020-10804
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2024-04-24

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.9.0, < 4.9.5 → fixed in 4.9.5 • Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.2 → fixed in 5.0.2

Description

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

Related

Alias · CVE (1)

  • CVE-2020-10804 In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in… vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References