GitHub Advisoryadvisory · Go
GHSA-h69v-mvh9-hfrq Mattermost Incorrect Authorization vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-5194
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2023-09-29
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 8.1.0, < 8.1.1 → fixed in 8.1.1
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0, < 8.0.2 → fixed in 8.0.2
• Go github.com/mattermost/mattermost-server/v6: < 7.8.10 → fixed in 7.8.10
Description
Mattermost fails to properly validate permissions when demoting and deactivating a user allowing for a system/user manager to demote / deactivate another manager
Related
Alias · CVE (1)
- CVE-2023-5194 Mattermost fails to properly validate permissions when demoting and deactivating a user allowing for a system/user manager to demote /… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness