GitHub Advisoryadvisory · PyPI
GHSA-h6hq-c896-w882 Plone Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2011-1949
- Ecosystem
- PyPI
- Packages
- Plone
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• PyPI Plone: >= 3.3.2, < 3.3.6 → fixed in 3.3.6
• PyPI Plone: >= 4.0a0, < 4.0.6 → fixed in 4.0.6
• PyPI Plone: >= 4.1a0, < 4.1.1 → fixed in 4.1.1
Description
Cross-site scripting (XSS) vulnerability in the safe_html filter in Products.PortalTransforms in Plone 2.1 through 4.1 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2010-2422.
Related
Alias · CVE (1)
- CVE-2011-1949 Cross-site scripting (XSS) vulnerability in the safe_html filter in Products.PortalTransforms in Plone 2.1 through 4.1 allows remote… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-1949 advisory
- https://exchange.xforce.ibmcloud.com/vulnerabilities/67694 web
- https://github.com/advisories/GHSA-h6hq-c896-w882 advisory
- https://github.com/plone/Plone package
- https://github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2011-15.yaml web
- http://plone.org/products/plone/security/advisories/CVE-2011-1949 web