GitHub Advisoryadvisory · Packagist

GHSA-h6px-pvfh-q2jv Moodle vulnerable to Cross-Site Scripting

LOW Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4299
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
Weaknesses
CWE-79
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 2.0.0, < 2.0.5 → fixed in 2.0.5 • Packagist moodle/moodle: >= 2.1.0, < 2.1.2 → fixed in 2.1.2

Description

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Related

Alias · CVE (1)

  • CVE-2011-4299 Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References