GitHub Advisoryadvisory · npm

GHSA-h6q6-9hqw-rwfv Misinterpretation of malicious XML input

MEDIUM Published 2021-03-12 Modified 2023-01-02 Official page ↗
Aliases
CVE-2021-21366
Ecosystem
npm
Packages
xmldom
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-115, CWE-436
Reviewed
2021-03-12

Affected packages

• npm xmldom: < 0.5.0 → fixed in 0.5.0

Description

Impact xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. Patches Update to 0.5.0 (once it is released) Workarounds Downstream applications can validate the input and reject the maliciously crafted documents. References Similar to this one reported on the Go standard library: • https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/ For more information If you have any questions or comments about this advisory: • Open an issue in `xmldom/xmldom` • Email us: send an email to all addresses that are shown by `npm owner ls xmldom`

Related

Alias · CVE (1)

  • CVE-2021-21366 xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module. vulnerability

Weakness · CWE (2)

  • CWE-115 Misinterpretation of Input weakness
  • CWE-436 Interpretation Conflict weakness

References