GitHub Advisoryadvisory · RubyGems

GHSA-h6rj-8r3c-9gpj bson is vulnerable to denial of service due to incorrect regex validation

CRITICAL Published 2018-03-05 Modified 2022-04-25 Official page ↗
Aliases
CVE-2015-4412
Ecosystem
RubyGems
Packages
bson
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-400
Reviewed
2020-06-16

Affected packages

• RubyGems bson: < 1.12.3 → fixed in 1.12.3 • RubyGems bson: >= 2.0, < 3.0.4 → fixed in 3.0.4

Description

BSON injection vulnerability in the legal function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.

Related

Alias · CVE (1)

  • CVE-2015-4412 BSON injection vulnerability in the legal? vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References