GitHub Advisoryadvisory · PyPI
GHSA-h6rp-mprm-xgcq plone.rest vulnerable to Denial of Service when ++api++ is used many times
MEDIUM
Official page ↗
- Aliases
- CVE-2023-42457
- Ecosystem
- PyPI
- Packages
- plone.rest
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-770
- Reviewed
- 2023-09-21
Affected packages
• PyPI plone.rest: >= 2.0.0a1, < 2.0.1 → fixed in 2.0.1
• PyPI plone.rest: >= 3.0.0, < 3.0.1 → fixed in 3.0.1
Description
Impact
When the `++api++` traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive.
Patches
Patches will be released in `plone.rest` 2.0.1 and 3.0.1. Series 1.x is not affected.
Workarounds
In your frontend web server (nginx, Apache) you can redirect `/++api++/++api++` to `/++api++`.
Related
Alias · CVE (1)
- CVE-2023-42457 plone.rest allows users to use HTTP verbs such as GET, POST, PUT, DELETE, etc. vulnerability
References
- https://github.com/plone/plone.rest/security/advisories/GHSA-h6rp-mprm-xgcq web
- https://nvd.nist.gov/vuln/detail/CVE-2023-42457 advisory
- https://github.com/plone/plone.rest/commit/43b4a7e86206e237e1de5ca3817ed071575882f7 web
- https://github.com/plone/plone.rest/commit/77846a9842889b24f35e8bedc2e9d461388d3302 web
- https://github.com/plone/plone.rest package
- https://github.com/pypa/advisory-database/tree/main/vulns/plone-rest/PYSEC-2023-178.yaml web
- http://www.openwall.com/lists/oss-security/2023/09/22/2 web