GitHub Advisoryadvisory · Maven

GHSA-h6w8-52mq-4qxc Apache Linkis contains Deserialization of Untrusted Data

HIGH Published 2023-01-31 Modified 2023-02-07 Official page ↗
Aliases
CVE-2022-44645
Ecosystem
Maven
Packages
org.apache.linkis:linkis
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2023-02-02

Affected packages

• Maven org.apache.linkis:linkis: < 1.3.1 → fixed in 1.3.1

Description

In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.

Related

Alias · CVE (1)

  • CVE-2022-44645 In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References