GitHub Advisoryadvisory · Packagist
GHSA-h72q-cq3w-h3wc Drupal CivicTheme Design System allows Cross-Site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2025-12083
- Ecosystem
- Packagist
- Packages
- drupal/civictheme
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-10-30
Affected packages
• Packagist drupal/civictheme: < 1.12.0 → fixed in 1.12.0
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CivicTheme Design System allows Cross-Site Scripting (XSS). This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.
Related
Alias · CVE (1)
- CVE-2025-12083 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CivicTheme Design System… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness