GitHub Advisoryadvisory · Packagist

GHSA-h7v2-2qwg-h829 Symfony has a security issue when parsing the Authorization header

MEDIUM Published 2024-05-30 Modified 2024-05-30 Official page ↗
Aliases
CVE-2014-6061
Ecosystem
Packagist
Packages
symfony/http-foundation, symfony/symfony
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-20
Reviewed
2024-05-30

Affected packages

• Packagist symfony/http-foundation: >= 2.0.0, < 2.3.19 → fixed in 2.3.19 • Packagist symfony/http-foundation: >= 2.4.0, < 2.4.9 → fixed in 2.4.9 • Packagist symfony/http-foundation: >= 2.5.0, < 2.5.4 → fixed in 2.5.4 • Packagist symfony/symfony: >= 2.0.0, < 2.3.19 → fixed in 2.3.19 • Packagist symfony/symfony: >= 2.4.0, < 2.4.9 → fixed in 2.4.9 • Packagist symfony/symfony: >= 2.5.0, < 2.5.4 → fixed in 2.5.4

Description

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony HttpFoundation component are affected by this security issue. This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.0, 2.1, and 2.2 as they are not maintained anymore. Description When an application uses an HTTP basic or digest authentication, Symfony does not parse the `Authorization` header properly, which could be exploited in some server setups (no exploits have been demonstrated though.) Resolution The parsing of the `Authorization` header has been fixed to comply to the HTTP specification. The patch for this issue is available here: https://github.com/symfony/symfony/pull/11829

Related

Alias · not in database (1)

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References