GitHub Advisoryadvisory · Packagist
GHSA-h7vf-5wrv-9fhv Symfony storing cookie headers in HttpCache
MEDIUM
Official page ↗
- Aliases
- CVE-2022-24894
- Ecosystem
- Packagist
- Packages
- symfony/http-kernel, symfony/symfony
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:L
- Weaknesses
- CWE-285
- Reviewed
- 2023-02-01
Affected packages
• Packagist symfony/http-kernel: >= 2.0.0, < 4.4.50 → fixed in 4.4.50
• Packagist symfony/http-kernel: >= 5.0.0, < 5.4.20 → fixed in 5.4.20
• Packagist symfony/http-kernel: >= 6.0.0, < 6.0.20 → fixed in 6.0.20
• Packagist symfony/http-kernel: >= 6.1.0, < 6.1.12 → fixed in 6.1.12
• Packagist symfony/http-kernel: >= 6.2.0, < 6.2.6 → fixed in 6.2.6
• Packagist symfony/symfony: >= 2.0.0, < 4.4.50 → fixed in 4.4.50
• Packagist symfony/symfony: >= 5.0.0, < 5.4.20 → fixed in 5.4.20
• Packagist symfony/symfony: >= 6.0.0, < 6.0.20 → fixed in 6.0.20
• Packagist symfony/symfony: >= 6.1.0, < 6.1.12 → fixed in 6.1.12
• Packagist symfony/symfony: >= 6.2.0, < 6.2.6 → fixed in 6.2.6
Description
Description
-----------
The Symfony HTTP cache system acts as a reverse proxy: it caches HTTP responses (including headers) and returns them to clients.
In a recent `AbstractSessionListener` change, the response might now contain a `Set-Cookie` header. If the Symfony HTTP cache system is enabled, this header might be stored and returned to some other clients. An attacker can use this vulnerability to retrieve the victim's session.
Resolution
----------
The `HttpStore` constructor now takes a parameter containing a list of private headers that are removed from the HTTP response headers.
The default value for this parameter is `Set-Cookie`, but it can be overridden or extended by the application.
The patch for this issue is available here for branch 4.4.
Credits
-------
We would like to thank Soner Sayakci for reporting the issue and Nicolas Grekas for fixing it.
Related
Alias · CVE (1)
- CVE-2022-24894 Symfony is a PHP framework for web and console applications and a set of reusable PHP components. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://github.com/symfony/symfony/security/advisories/GHSA-h7vf-5wrv-9fhv web
- https://nvd.nist.gov/vuln/detail/CVE-2022-24894 advisory
- https://github.com/symfony/symfony/commit/d2f6322af9444ac5cd1ef3ac6f280dbef7f9d1fb web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-kernel/CVE-2022-24894.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2022-24894.yaml web
- https://github.com/symfony/symfony package
- https://lists.debian.org/debian-lts-announce/2023/07/msg00014.html web
- https://symfony.com/cve-2022-24894 web