GitHub Advisoryadvisory · RubyGems

GHSA-h835-75hw-pj89 activesupport Cross-site Scripting vulnerability

MEDIUM Published 2017-10-24 Modified 2025-01-21 Official page ↗
Aliases
CVE-2012-3464
Ecosystem
RubyGems
Packages
activesupport
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems activesupport: >= 3.0.0.beta, < 3.0.17 → fixed in 3.0.17 • RubyGems activesupport: >= 3.1.0, < 3.1.8 → fixed in 3.1.8 • RubyGems activesupport: >= 3.2.0, < 3.2.8 → fixed in 3.2.8 • RubyGems activesupport: < 2.3.16 → fixed in 2.3.16

Description

Cross-site scripting (XSS) vulnerability in `activesupport/lib/active_support/core_ext/string/output_safety.rb` in Ruby on Rails before 2.3.16, 3.0.x before , 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.

Related

Alias · CVE (1)

  • CVE-2012-3464 Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References