GitHub Advisoryadvisory · PyPI

GHSA-h896-6hcp-gj6c Bodhi Cross-site Scripting Vulnerability

MEDIUM Published 2022-05-13 Modified 2024-09-04 Official page ↗
Aliases
CVE-2017-1002152
Ecosystem
PyPI
Packages
bodhi
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-22

Affected packages

• PyPI bodhi: < 2.9.1 → fixed in 2.9.1

Description

Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.

Related

Alias · CVE (1)

  • CVE-2017-1002152 Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References