GitHub Advisoryadvisory · Packagist
GHSA-h8m4-h385-qhqv Moodle Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2021-20186
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.10, < 3.10.1 → fixed in 3.10.1
• Packagist moodle/moodle: >= 3.9, < 3.9.4 → fixed in 3.9.4
• Packagist moodle/moodle: >= 3.8, < 3.8.7 → fixed in 3.8.7
• Packagist moodle/moodle: >= 3.5, < 3.5.16 → fixed in 3.5.16
Description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.
Related
Alias · CVE (1)
- CVE-2021-20186 It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness