GitHub Advisoryadvisory · Maven

GHSA-h8q5-g2cj-qr5h Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

HIGH Published 2018-10-17 Modified 2022-04-26 Official page ↗
Aliases
CVE-2018-11796
Ecosystem
Maven
Packages
org.apache.tika:tika-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-611
Reviewed
2020-06-16

Affected packages

• Maven org.apache.tika:tika-core: >= 0.1, < 1.19.1 → fixed in 1.19.1

Description

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Related

Alias · CVE (1)

  • CVE-2018-11796 In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References