GitHub Advisoryadvisory · Go
GHSA-h8wh-f7gw-fwpr Mattermost Incorrect Authorization vulnerability
LOW
Official page ↗
- Aliases
- CVE-2023-5193
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v6
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2023-09-29
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 8.1.0, < 8.1.1 → fixed in 8.1.1
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0, < 8.0.2 → fixed in 8.0.2
• Go github.com/mattermost/mattermost-server/v6: < 7.8.10 → fixed in 7.8.10
Description
Mattermost fails to properly check permissions when retrieving a post allowing for a System Role with the permission to manage channels to read the posts of a DM conversation.
Related
Alias · CVE (1)
- CVE-2023-5193 Mattermost fails to properly check permissions when retrieving a post allowing for a System Role with the permission to manage channels to… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness