GitHub Advisoryadvisory · Maven
GHSA-h97r-fchm-m23x Cross-site Scripting in Jenkins Email Extension Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2023-25763
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:email-ext
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-02-15
Affected packages
• Maven org.jenkins-ci.plugins:email-ext: < 2.94 → fixed in 2.94
Description
Jenkins Email Extension Plugin 2.93 and earlier does not escape various fields included in bundled email templates, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control affected fields.
Related
Alias · CVE (1)
- CVE-2023-25763 Jenkins Email Extension Plugin 2.93 and earlier does not escape various fields included in bundled email templates, resulting in a stored… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25763 advisory
- https://github.com/jenkinsci/email-ext-plugin/commit/ebfb97475ec6491f28b88a8b5acbb99ff36f4d7f web
- https://github.com/jenkinsci/email-ext-plugin package
- https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-2931 web
- http://www.openwall.com/lists/oss-security/2023/02/15/4 web