GitHub Advisoryadvisory · Maven

GHSA-h9mh-mgpv-gqmv Remote code execution in Apache Flume

CRITICAL Published 2022-08-22 Modified 2022-08-30 Official page ↗
Aliases
CVE-2022-34916
Ecosystem
Maven
Packages
org.apache.flume.flume-ng-sources:flume-jms-source
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-74
Reviewed
2022-08-30

Affected packages

• Maven org.apache.flume.flume-ng-sources:flume-jms-source: >= 1.4.0, < 1.10.1 → fixed in 1.10.1

Description

Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Related

Alias · CVE (1)

  • CVE-2022-34916 Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References