GitHub Advisoryadvisory · Packagist

GHSA-hc67-v29c-7g78 Cross-site Scripting in DaSchTour matomo-mediawiki-extension

MEDIUM Published 2023-02-05 Modified 2023-10-20 Official page ↗
Aliases
CVE-2017-20175
Ecosystem
Packagist
Packages
mediawiki/matomo
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-02-14

Affected packages

• Packagist mediawiki/matomo: < 2.4.3 → fixed in 2.4.3

Description

A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The name of the patch is 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.

Related

Alias · CVE (1)

  • CVE-2017-20175 A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References